PDA

View Full Version : Images in Sales or landing pages



bobm
07-01-2010, 08:43 AM
I've been having problems getting images to upload or appear in the sales or landing pages. For example - I'd like to use a custom header image at the top of the page but all I get is a box with red x in it. Any suggestions on doing this would be much appreciated.

Thanks - Bob M

lynnth
07-01-2010, 08:47 AM
I would use the WordPress media system to upload the images to your site. Then take the path that the media library provides within your pages.

bobm
07-01-2010, 12:27 PM
Thanks - where do I find the WP media and library.

Bob M

lynnth
07-01-2010, 12:30 PM
The WordPress menu down the left side has a button for Media. It opens up to a link for Add New.

bobm
07-01-2010, 12:57 PM
I would use the WordPress media system to upload the images to your site. Then take the path that the media library provides within your pages.

Could you please explain this part a little more? "Then take the path that the media library provides within your pages."

Thanks

lynnth
07-01-2010, 01:05 PM
When you add something to the media library it is uploaded to a folder on your site based on the year and month the upload occurred. When the upload is complete it will display a page of information. One piece of information near the bottom of that page is the full path to the file on your site. It will look something like:
http://domain.com/wp-content/uploads/2010/06/picture.jpg

With the domain being your site domain and picture.jpg being whatever you uploaded.

bobm
07-01-2010, 06:08 PM
OK - thanks much!

bobm
07-03-2010, 05:42 PM
When you add something to the media library it is uploaded to a folder on your site based on the year and month the upload occurred. When the upload is complete it will display a page of information. One piece of information near the bottom of that page is the full path to the file on your site. It will look something like:
http://domain.com/wp-content/uploads/2010/06/picture.jpg

With the domain being your site domain and picture.jpg being whatever you uploaded.

I'm really sorry to be a pest about this quesiton - but I'm still having problem with images showing up in the sales - landing or skinny pages. I upload or insert a photo from the media libray but all I get when I view the page is a box with a a small red x in it. I'm not sure what I'm doing wrong.

I'm anxious to use these pages but can't seem to get past this issue. Any suggestions would be much appreciated.


Bob M

lynnth
07-04-2010, 10:40 AM
Bob,

Best bet is for you to PM me a temporary admin login for the site.

lynnth
07-08-2010, 05:41 AM
Bob,

I was able to get into your dashboard. Based on what I'm seeing you have a directory permissions problem with your upload folder or the folders under it. It is allowing you to write (i.e. upload) images into it but not allowing you to read from them. The permissions on the upload folder and all folders below it should be 755.

bobm
07-08-2010, 08:09 AM
Thank you - you've been very helpful and paitient I might add. I did hit the scale button at the top.

One last thing and I'll quit pestering you. Where do I go and what do i do to change the permission?

Thanks Much - bob M

lynnth
07-08-2010, 08:26 AM
Bob,

You're welcome. And don't worry about pestering us. Phil, Eric and I are volunteers who believe in Socrates enough to volunteer our time to help other users. We want to help.

You have two approaches to setting the permissions depending on how technical you want to get. The least technical for most people is to go into your hosting control panel (cPanel for most folks). In there is an application called File Manager. You can use it to navigate through all of the files and folders that make up your site. Go down to the uploads folder under wp-content and select that folder. Along the top there are actions you can take and one of the actions if permissions. Click it and set the permissions to 755. In most panels there is also a checkbox to say that children inherit permissions. Checking this box will take care of all of the folders under uploads.

The slightly more technical approach is to use a FTP client like Filezilla. You give it your hosting login information and log into your site with it. On the right side (in the case of Filezilla) you have a file manager similar to the one found in cPanel. You use it to navigate down to the folder you want. Depending on the FTP software there will either be a button up on the toolbar for setting permissions or you can right click on the folder and a pop-up menu will give you that option. There is usually an option for setting children here as well.

bobm
07-08-2010, 11:47 AM
Thank you very much!

Bob M