PDA

View Full Version : Turning off Date/Time/Author on post



sbdcouncil
07-02-2010, 10:50 AM
In the list of new features it says that we can now turn off the date, time, author tags on each post.

I don't see where to do that.

Anyone know?

Thanks,

Jim

lynnth
07-02-2010, 10:54 AM
On the Socrates layout page there is a selection labeled Post Display Settings

sbdcouncil
07-02-2010, 12:28 PM
Looked and looked and couldn't find it.

Thanks for telling me where!

Jim

mack45
08-18-2010, 09:51 AM
Thanks Linnth I found the post for on and off right away but I can see it being frustrating for people learning WP and Socrates. It is becoming my stand by for web sites on marketing.

marsland
08-24-2010, 04:40 PM
I've found the setting for turning off the display for author and date, but this seems to work only for Default Profile. I have an Disclaimer Page and a Terms page that are cast on the No Sidebars profile, and they are showing the author/date.

Am I missing something?

http://getwealthdirection.com


Thanks
john

mack45
08-24-2010, 05:30 PM
Hi If you are using Word press you may need to stop it there also go to settings >general. then set to custom setting and just leave it blank hope that solves it for you Yeah hit save changes:)

marsland
08-24-2010, 09:59 PM
I think I've discovered a bug and/or feature.

I can go to the Socrates/Layout panel and select Post Display Settings = Off, and that will remove the Author/Date from my Posts. However, will it also remove Author/Date from my Pages? Sometimes. If I use the Default Template for the page, then yes, that page will suppress the Author/Date line. However, if I select No Sidebars, the Author/Date will reappear.

It seems that Socrates Layout Post Display=Off does not work with some Page layouts.

John

:confused:

marsland
08-24-2010, 10:02 PM
There is a response from admin in the bugs/fixes forum that shows how to remove posts from static pages that have no sidebars template. search that forum for "Static Pages looking like Posts" for the fix.

john

marsland
08-24-2010, 10:17 PM
In the Appearance/Editor, you have the ability to change the page layout php files. In order to suppress the author/date from a page with the No Sidebars layout, I have to go into the php and get rid of the "div ... post/author..." entry.

What is the best way to do that? I attempted to comment it out with /** */ as suggested in the header of that file, but it didn't work... just got an author line with /** in it.

How should I comment out stuff? Alternatively, if I delete stuff and screw things up, where do I find the revisions or original files for the layout php files?

thanks.
john

Dan Nickerson
08-25-2010, 10:52 AM
First you have a backup simply by having the Socrates.zip file on your desktop. It has all our original files.

Next, before you edit a file just copy and paste it into notepad and save it in a Socrates folder as a backup.

When editing I have a tendency to just delete the full div line.

To comment out you would use <!-- in front and -- > at end

<!--
<div class="postAuthor">By <?php the_author_posts_link(); ?> on <?php the_time('l, F jS, Y') ?> | <?php comments_popup_link('No Comments', '1 Comment', '% Comments'); ?></div>
-->

Principal22
08-31-2010, 10:45 PM
What am I missing - I cannot find any mention on the layout page to take out date and author.

Specifically where is it?

Thanks,

Lauren

Dan Nickerson
08-31-2010, 11:49 PM
What version of Socrates are you using? Upgrade to 2.03 if using older version.

marsland
09-01-2010, 12:10 AM
Lauren,

In Socrates/Layout, look for Post Display Settings, and check the Off button.

This assumes a somewhat recent version, so if it's not there, upgrade to the current version.

John

EHiatt121
09-01-2010, 06:19 AM
It kind of hides in plain sight. Myself and many others have looked right past it, but its there.