PDA

View Full Version : index.php appears to bring up an error page



elementalist
07-04-2010, 12:58 PM
When you go to my site the following comes up in the main body:



Not Found

Sorry, but you are looking for something that isn't here.
Search for: <there is a search box here>


I never created any such page, but that is where you land when you go to the site.


The sidebar is there on the right, with the pages (1), categories (0), etc., but the page I wish to be the home page (#1) appears only when you click on the page link in the sidebar. How do I make this the index page?

lynnth
07-04-2010, 01:41 PM
sounds like a permalink issue. Are your permalinks set to custom and /%postname%/

Please post the URL to the site so we can take a look.

elementalist
07-04-2010, 03:56 PM
Thanks Lynn. I'm very new to all of this. I should have given the link so you can see. I've just started toying with Wordpress, etc. The site is:

http://anxiety-management.net

It defaults to an error page, as you should see. Not sure how Permalinks could do this.

Dan Nickerson
07-04-2010, 04:57 PM
You have no posts... so that's why you're seeing a "not found" message.

Step 1. Setup Permalinks

Settings > Permalinks

Set Custom structure to: /%postname%/

Step 2. Create a new Post

Posts > Add New

This will then show on your main page.

Step 3. If you haven't created a contact page, goto Pages > Add New, select Contact Template from right hand drop down, fill out fields and save.

Once you do the above the site will function much better.

If you want to make your one current page the homepage, goto:

Settings > Reading

and select that page as your front page.

That will also remove the not-found message.