PDA

View Full Version : My Header Won't Upload, What's Wrong?



Pages : [1] 2

Dan Nickerson
07-07-2010, 11:10 AM
First make sure...



The file is 960x150 pixels in size
The extension ends in .jpg, .gif, .png
There are no numbers, spaces or punctuation in filename

If you are receiving a header upload error..

Goto Settings > Miscellaneous (or Settings > Media in 3.0)
and save the upload path as

wp-content/uploads

If that doesn't work chmod the permissions on the header-images and sub directories via FTP to 777. Change back to 755 permissions if fixed.

Search forum for more solutions if this doesn't solve.

sailorsaml
07-08-2010, 10:29 PM
Thanks Dan,

That didn't make much sense to me since I am using one of the stock headers.

When I select it, no problem, then I click save and it goes away every time. :confused:

I am seeing this error message just above the header images to choose:

Warning: opendir(../wp-content/themes/socrates/header-images/uploads) [function.opendir]: failed to open dir: No such file or directory in /home/samuel/public_html/hawaiisolarcompany.com/resources/wp-content/themes/socrates/socrates/functions.php on line 2065

Please help, thanks.

Sam

Dan Nickerson
07-08-2010, 10:48 PM
You've got a double directory problem, which means you unzipped it to a 2nd directory and uploaded..

Look at your directory path.

/socrates/socrates

Via FTP move all the files from socrates/socrates/ to just /socrates

That will fix.

LLFiggs
07-09-2010, 10:37 AM
Lovin' this theme, but having trouble here and there.

I watched the tutorial & followed the steps to upload a custom header from my logo software. It's the right size, a jpg file & I removed the spaces & punctuation from the name. When I press "Upload" the file seems to be uploading & I get a message saying the change has been made. But instead of my custom image in the Uploads section, I keep getting images from the Socrates library. I've tried over and over and over. Same result. No error messages, though.

I'm a web neophyt & don't know how to do any technical troubleshooting. Please help!!

The site is under development & set to private right now but the address is www.TLFiggs.com/wordpress

LaCharla

lynnth
07-09-2010, 10:56 AM
It is very strange. I see an image of a bible passage in the header when I look at your site. But if I look at the source to the page I don't see where that image is called out.

sailorsaml
07-09-2010, 11:55 AM
You've got a double directory problem, which means you unzipped it to a 2nd directory and uploaded..

Look at your directory path.

/socrates/socrates

Via FTP move all the files from socrates/socrates/ to just /socrates

That will fix.


Thanks Dan, I have FileZilla and I see the other directory paths, just not sure HOW to move the files from socrates/socrates/ to just /socrates. There is no cut and paste feature in File Zilla that I see.

Any ideas? Thank you!:cool:

lynnth
07-09-2010, 12:01 PM
With Filezilla it is drag and drop. Select the lower socrates folder and drag it up a level.

sailorsaml
07-09-2010, 12:24 PM
Do I delete the secondary one after I drag it up? I noticed that there is also one for MACOSX, should I do the same for that? Thank you!;)

lynnth
07-09-2010, 12:32 PM
Once you drag the lower Socrates folder up into the themes folder it should merge the two. This is fine since the upper one only contains the lower one. Not sure what the MACOSX folder is. Might be another theme.

Dan Nickerson
07-09-2010, 12:48 PM
The MacOSX folder might have been placed in there on an old version... blame Jon... he sends me updates that he zipped in Mac... so I might have missed one in an older update.

Dan Nickerson
07-09-2010, 12:48 PM
LaCharla,

If you want to email me/private message me access I can take a look.

LLFiggs
07-09-2010, 04:42 PM
It is very strange. I see an image of a bible passage in the header when I look at your site. But if I look at the source to the page I don't see where that image is called out.

I tried adding 3 different random headers just to be sure the feature worked. The built-ins all work fine. At first, I neglected to save the solid color that I returned to after the custom header upload failed. It's back to the solid now.

By the way, since I'v just transferred--and not edited--data from my old site, I set each page to "Private." I thought this made it unavailable to others. Can you please explain how that works?

LaCharla

Dan Nickerson
07-09-2010, 05:42 PM
Private pages don't show up in navigation or page widgets.

They can still be accessed if people know the link address.

You also have a problem with your permalinks... They're not
set up correctly.

Should be custom structure

/%postname%/

I can fix once you send the login

LLFiggs
07-09-2010, 06:12 PM
Private pages don't show up in navigation or page widgets.

They can still be accessed if people know the link address.

You also have a problem with your permalinks... They're not
set up correctly.

Should be custom structure

/%postname%/

I can fix once you send the login


Oh boy. Tech stuff!
I can't find a link to send you a PM with the code.

Dan Nickerson
07-09-2010, 06:18 PM
Just click on my "username" or use the contact form.

I'm about to head out to dinner shortly, but can fix later.

LLFiggs
07-10-2010, 06:05 PM
Just want to acknowledge and thank Admin Dan for helping me late into the night last night with my tech issues. The final answer was the one, Dan!!

The reason my custom headers wouldn't upload was obviously my web browser, Internet Explorer 8. I downloaded Mozilla Firefox in less than 5 minutes, and the problem VANISHED!

A million thanks for your dedication and persistent help!!

Cheers,
LaCharla

Dan Nickerson
07-10-2010, 09:08 PM
LaCharla,

You're welcome... are you sure you had IE8.. it should work fine in IE8, but IE6 & IE7 do have issues.

That being said.. switching to Firefox is the best decision you could make... It's far superior, faster and more friendly to marketers.

Virpi
07-13-2010, 08:38 AM
Hi,

This is what happens with the Socrates theme version 2.03 when custom header image is uploaded (does not happen).

When uploading a custom header (size 960px 150px, jpg, no spaces, punctuaion or other symbols in the name), Socrates seems to upload and gives a notification "Your changes have been saved" but when viewing the "Uploads" section in the Header image selection, it only shows the stock image currently chosen for the blog header, no uploads.

When checking the folder on the server at /themes/socrates/header-images/uploads no uploaded images there.

When I ftp'ed the custom header image to the location mentioned above, and refreshed the wp-admin view, the custom header appeared and at the same time the theme downloaded all the stock header images already in the datbase from Socrates themes' Amazonaws account...

I installed Socrates without unzipping it on my computer, fitst installation (no upgrade from older versions), and there seem not to be this "socrates/socrates" double folder problem.

Please check the upload function, thanks.

Dan Nickerson
07-13-2010, 08:49 AM
Virpi,

You were very clear in your post, but did you do this as well?


If you are receiving a header upload error..

Goto Settings > Miscellaneous (or Settings > Media in 3.0)
and save the upload path as

wp-content/uploads

If that doesn't work chmod the permissions on the header-images and sub directories via FTP to 777. Change back to 755 permissions if fixed.

Virpi
07-13-2010, 09:34 AM
Thanks for your prompt reply.

Checked the Settings > Media, by default the upload path already was
"wp-content/uploads"

changed chmod of the header-images and uploads folder to 777

and yet the the problem persists: can't upload a custom header using the upload feature in Socrates themes header c-panel.

Never mind, got the headers uploaded with ftp, and because this is basically one time thing for each blog, it's doable.

However, because I wasn't the only one with this problem, it can cause unnecessary frustration for others as well before it's fixed, hopefully for the next version.

Dan Nickerson
07-13-2010, 09:41 AM
Virpi,

It's either an issue with..



Browser - wont' work in IE6 or IE7
Bad Install - reinstall
Permissions - server didn't set proper permissions
Webhost - webhost doesn't allow uploads


We have many 1000's of users and it's a rare issue. Other users had issues but the above always solves it. It's not something we're working on a fix for.

If you would like to send me your WP and FTP login info via PM I can probably fix in a minute.

bean42
07-16-2010, 08:36 AM
I have done all of the above mentioned suggestions and I still can't get a custom header to work. I'm starting to build out this blog www.schmutzerland.com/blog maybe if you take a look you can give me some advice. Thanks

lynnth
07-16-2010, 08:40 AM
Are you remembering the step that after uploading the header you need to go to the header displays below that and select it under the upload category? Some people miss that you need to do this step.

bean42
07-16-2010, 08:57 AM
Yes, when I look at the upload area all I see is a broken image Icon and the image doesn't show. I'm ftp-ing right into the uploads folder in the header-images folder.

LLFiggs
07-16-2010, 09:49 AM
After I changed my browser from Internet Explorer 8 to Mozilla Firefox, all the basic instructions worked fine EXCEPT that when I upload the image, it automatically appears as the header---without my having to go back to the UPLOAD bar at the bottom. Just sharing for general info....

bean42
07-16-2010, 01:37 PM
I am using Firefox (the most recent version). I have the image I want sitting in the uploads folder, it just won't show up in Socrates. I've tried everything from renaming it to match one of the preset images to trying to write the image name in the source code and nothing seems to work.

lynnth
07-17-2010, 03:46 AM
Everything points to not having read permission on the folder. Make sure all of the folders in the upload folders path have at least 755 permissions set.

gogvo
07-18-2010, 05:43 AM
Hello when i click in on the uploaded image to confirm my custom header, I am knocked out of the site... Then I can not log back in unless I go via the meta section on the blog itself?

Very strange... also I ftped the header on to the server and nothing?

Dan Nickerson
07-18-2010, 09:10 AM
This issue is almost always caused by your settings in Settings > General

Make sure your blog url and wordpress url are identical.

Either both with "www" or both "non-www"

bean42
07-19-2010, 04:40 AM
Everything points to not having read permission on the folder. Make sure all of the folders in the upload folders path have at least 755 permissions set.

Sorry for taking so long to get back to you, but I had a hectic weekend.

I have made all your recommended changes and still cannot add a custom header. Every time I upload, I see a broken image icon in the upload section of Socrates. I can see the file in the uploads folder on the server, but it will not show up on my blog.

shahone1@gmail.com
07-19-2010, 07:09 AM
Hello when i click in on the uploaded image to confirm my custom header, I am knocked out of the site... Then I can not log back in unless I go via the meta section on the blog itself?

Very strange... also I ftped the header on to the server and nothing?

____________________

The same thing happened to me when I was starting off with Socrates.
I followed instructions -given on forum by a helpful fellow member- and they worked for me. Perhaps they'll work for you as well.
Please try this:

Go to your dashboard in Wordpress.
Go to Settings > General
On General settings page make sure that the WordPress address (URL), and th Site address (URL) are the same. If one starts with www i.e http://www.yourdomain.com[/url] then the other one should also be the same i.e. http://www.yourdomain.com.
Save changes and this should fix the problem of your getting knocked out of the site when attempting to upload a header.

Good Luck.


www.brainytipsblog.com
www.shah111.com

bean42
07-19-2010, 09:52 AM
OK, folks, thanks for all the replies and help, but I have done all of the suggestions offered and I still can't get a custom header to work. If any one has come across another solution I'd really appreciate it.

Thanks

lynnth
07-19-2010, 09:55 AM
If you want to email me the URL, a temporary admin username and password and the header file, I will give it a try for you. I will delete my email from this post as soon as I receive the email.

bean42
07-19-2010, 10:15 AM
Wow, it looks like I finally got it. I changes all my permissions to 777 and FTP-ed directly into the uploads folder and the changes finally worked

lynnth
07-19-2010, 10:20 AM
Good to hear. For most people 755 will work. I guess it is partially host dependent. Please edit your previous post to remove my email address (don't want the spam bots grabbing it).

davidis
08-09-2010, 07:41 AM
I switched from IE8 to FireFox and my header loaded on the first try.

David Griffiths
http://www.kids-tent.com

shabb47
08-11-2010, 03:13 PM
Okay this is the second time this has happened to me. I pick one of the business headers, it shows in dash but when I go to site, it's not there, the default shows up! So frustrating!!! Why does this keep happening, how to fix it?

Dan Nickerson
08-11-2010, 03:29 PM
Do you have wp super cache enabled?

shabb47
08-13-2010, 05:28 AM
Dan,

Thanks, but it finally went through, I just kept trying. What is super cache?

Lisa

lynnth
08-13-2010, 05:49 AM
WP Super Cache is a plug-in that speeds up your web site by keeping an HTML image of each page. Downside is that if you make changes while it is active, you might not see them right away. Read more about it here: http://lynntharrison.com/the-dangers-of-wp-super-cache/

msaville
08-23-2010, 12:11 PM
I had the same trouble uploading a customer header as some of the other people on the Forum. I checked that it is a jpg file with no gaps or punctuation in the title. It is 960x150 in size. I checked that wordpress and the site are the same url. I have wp-content/uploads set. I changed the settings to 777 and have IE8 installed. It didn't upload so I uploaded it manually into themes/socrates/header-images/uploads following an earlier post. My customer header is now showing in the uploads section in Socrates. Now when I go to the site all that is showning is part of my custom header and nothing else. The site is http://runningandfundraising.com Could you please advise me what to do to correct this.
Many thanks

davidis
08-23-2010, 04:47 PM
Is the title in your header a part of the image? If it is, the search engines will not give you credit for your keyword.

Since the image does not fit, I have to ask again, is it a 72 dpi .jpg, .png. or .gif? It looks like an image size problem.

My upload problem was solved when I switched from IE8 to Firefox.

I am fairly sharp on graphics; however, I think I am having more problems with Socrates than anyone else here.

David Griffiths
Kids Tent (http://www.kids-tent.com)

Dan Nickerson
08-23-2010, 05:29 PM
Your main page has an xsitepro code to display a header

The actual image is at:
http://runningandfundraising.com/images/Running.jpg

And you'll notice it says PNG in the title bar, which is strange.

Where is your socrates install?

msaville
08-23-2010, 10:41 PM
I have got into a right mess trying to upload a customer header. I want to try and get back to the original position. I have deleted to customer header and reuploaded one of the standard headers. Everything in Socrates looks ok but my site doesnt load. I get an error message saying the link is broken. Can you advise how to correct this problem

Dan Nickerson
08-23-2010, 11:15 PM
You don't have a wordpress index.php file.

So that's where I'd start.. download the latest zip from wordpress.org, unzip it and then FTP the index.php file to your root directory

msaville
08-23-2010, 11:50 PM
Many thanks. The site is back to how it was. I think I'll do a body swerve on custom headers in the future.
Regards
Mike

gigiswealth
08-28-2010, 10:23 PM
You've got a double directory problem, which means you unzipped it to a 2nd directory and uploaded..

Look at your directory path.

/socrates/socrates

Via FTP move all the files from socrates/socrates/ to just /socrates

That will fix.

Hi, I am havingthe same problem. I am thinking that my header I am trying to uploaded is not loading.

So, I went to my FTP file but the only thing is I don't know how to change all the files from socrates/socrates/ to just /socrates.

How do I do that?

Thanks for your help in advance
ps: I am kind of new at this.

Dan Nickerson
08-29-2010, 09:38 AM
In FTP highlight all the files in /socrates/socrates

And then drag them to /socrates

Or just delete both directories and reinstall.

alexissalaam
09-01-2010, 04:08 PM
The MacOSX folder might have been placed in there on an old version... blame Jon... he sends me updates that he zipped in Mac... so I might have missed one in an older update.


Hi Dan I might be in the wrong thread but can you help me
my sociable links wont show on my home page they show on
the about me page and privacy policy page can you tell me the problem.


www.beginningbluesguitarlessons.com

Dan Nickerson
09-01-2010, 04:20 PM
Go into your sociable settings and set them to display on home page.

alexissalaam
09-01-2010, 04:45 PM
Go into your sociable settings and set them to display on home page.

Dan I did that its still not showing if its showing for the other 2 why not the home page

Dan Nickerson
09-01-2010, 05:23 PM
Because you have the wp super cache plugin activated.. deactivate it and reload.

rickblackmon
09-01-2010, 07:08 PM
First off, I am not a novice. I am a retired computer engineer with over 50 years in computers (Repair, design, manage, etc.) Having said that, I have watched the video two times. Then I started going through the steps of customizing the header.

I am getting the following error: Warning: opendir(../wp-content/themes/socrates/header-images/uploads) [function.opendir]: failed to open dir: Permission denied in /home/desktop/public_html/wp-content/themes/socrates/functions.php on line 2064

My permissions are all set to 777. I followed the thread all the way through here in the forum. I do not find a Setting, or a Media relating to Socrates.There is a 960x150 jpg file named logo,jpg in the uploads file. When I select one to the standard layouts, it is on the dashboard until I click save, then it reverts to a background with text that I typed in.

I have not reloaded the theme yet, but I guess that would be a last resort. I am not finding it as easy as everyone seems to be saying.to start with, at least as far as the header is concerned. I have been using the Flexibility 2 theme.

If you need a link to the site PM me and I will provide. My system is Win XP Pro SP3 with all updates, 3ghx, 6gb ram.

Dan Nickerson
09-01-2010, 07:44 PM
I notice your path says /home/desktop/

Are you actually trying to install on a pc? Or on a website? Because our headers remote load, they won't work offline.

I know you'll say you can give me access to the site and that would be great if you could PM me.. but you also give me your operating system which isn't a factor.

Can you clarify that?

Also how did you install? FTP or via dashboard?

rickblackmon
09-02-2010, 07:21 AM
BTW, I included the operating system since most places ask for it.

I tried installing via Dashboard on a brand new website with a new installation of WP 3.0. I received unpacking errors doing it this way. It failed to unpack one of the backgrounds, and I received installation.

Then, on this same website, I reinstalled WP, unzipped Socrates, uploaded the Socrates folder with all files via FTP. I set the permissions on functions.php and header.php to 777. I have a Install Successful indication (The Scrates News on the Dashboard.) I then selected Rose for the preset color scheme. I clicked Save. Then I selected the Header Health option with what looks like an eye chart. Before I clicked Save, every thing looked OK. I clicked Save and received no errors. When I go to the site, the only thing I see in the header is the text.

I will PM you the info on the site.

UBOSJE
09-25-2010, 01:42 PM
Hi Dan,

I also have issues loading a banner/header (i see the picture but when I save the picture turns white with the red X on the upper left side) and tried most of the above. the only thing i have not tried is copying the header images directly from my computer to the hosting server after unzipping the socrates file onmy computer. However, i cannot seem to findthe header-images and the folder header-images is actually empty after unzipping.

Any tips ? Thanks !

PS: when installing socrates on the hosting server I unzipped it through wordpress so that should be all oke to start with I think

Dan Nickerson
09-25-2010, 10:19 PM
If you're using IE try accessing with another browser.

Make sure your socrates is installed a in a directory named: socrates

Try reinstalling Socrates if persists.

gogvo
09-27-2010, 05:24 AM
Hello Dan... No matter what I do, the custom header will not upload and I have followed every instruction found on the forum... Totally lost on this!

Dan Nickerson
09-27-2010, 09:52 AM
Can you give us any more information?

1. What Browser are you using?
2. What's your filename? Including extension?
3. What's your operating system?
4. What error are you receiving?

Can you try renaming the file to something else like: header.jpg
and uploading?

gogvo
09-28-2010, 06:36 AM
The solution was to not use Internet explorer! Dan... I used firefox and it did the job first time.

Why do I use internet explorer at all? I wasted a lot of time for such a simple solution. :confused:

UBOSJE
09-28-2010, 12:34 PM
Hi Dan, i continue to have issues with my header, which are the pre-programmed ones you offer in socrates (so not uploading any other content). I am using firefox and I don't have a socrates/socrates folder but my socrates folder can be found directly under themes within wordpress. I think I have completed all other layout steps including background.

Any other things I could try to make this work :( . (site in progress is www.board-games-collector.com)

Thanks

Dan Nickerson
09-28-2010, 12:38 PM
Did you upload Socrates via FTP or your WP Dashboard?

If FTP, it's probably a permissions issue.

What path are you media uploads set to?

Should be wp-content/uploads

Who is your webhost if above doesn't help...

UBOSJE
09-28-2010, 12:53 PM
Did you upload Socrates via FTP or your WP Dashboard? Via WP Dashboard, using the zip file (structure seems fine)

If FTP, it's probably a permissions issue. I put everything at 777 just to be sure

What path are you media uploads set to? not sure where i can check this but I am only using the headers that came standard with socrates (tried several)

Should be wp-content/uploads

Who is your webhost if above doesn't help... webhosting firm is antagonist (holland)

Dan Nickerson
09-28-2010, 01:02 PM
actually everything at 777 can cause issues

only the uploads folder should be 777, socrates and header-images directory should be 755

the media path is in Settings > Miscellaneous or Settings > Media depending on your version.. that's where I'd check.

Finally if you can PM me access I can take a look.

Dan Nickerson
09-28-2010, 01:11 PM
It was your media path for uploading files in Settings > Media

I just changed it to wp-content/uploads

Wordpress's recommended setting

Dan Nickerson
09-28-2010, 01:12 PM
spoke to soon... hold on..

Dan Nickerson
09-28-2010, 01:13 PM
It's a server permission error. I need FTP access to fix..

UBOSJE
09-28-2010, 01:17 PM
Dan, I have send you a PM with some more info. thank for the help !

UBOSJE
09-28-2010, 05:06 PM
Hi Dan, thanks v much for a quick fix and great service !

alexbkk
11-08-2010, 09:59 AM
Hi!
I was just trying to install The Socrates, as I have done before without any difficulties(I have the unlimited license), and it uploaded fine, but when it was time to activate the plugin, this was the message I got/I am getting! "The plugin does not have a valid header.:
This make me confused as I am not very much of a techie--).
Could anyone provide me with hopefully an easy solution?
Sincerely,
Alex Torp
P.S.
I am using WP Dashboard to deal with the uploading. Actually I have done that every time I have installed a Socrates plugin, and except for a couple of bugs in the beginning of the release(I think?)it works very fine.

Dan Nickerson
11-08-2010, 01:44 PM
What plugin are you referring to?

Are you confusing our theme with our plugin, or perhaps trying to upload the theme using the plugin manager, instead of theme uploader?

alexbkk
11-09-2010, 06:21 AM
Hi!
Thanks for quick reply!
I am referring to the Socrates itself!!
I installed on my site, but the problems I described earlier occured when I tried to activate it.

My website is www.onedigitalnetwork.com

Dan Nickerson
11-09-2010, 08:49 AM
If you would like to PM me access I can install.

But I would recommend just reinstalling making sure you are using the theme uploader.

As you probably saw on a forum search others who have had the same issue were trying to upload via the plugin manager.

The Ungifted Marketer
11-13-2010, 09:52 AM
Hi all

looking for some help please with headers.... i have installed socrates all went ok no problems but when i go to change the header to one in the template i get the following ?

Not Found

The requested URL /wp-admin/admin.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request

or

Oops! This link appears to be broken.
Suggestions:
Search on Google:


Can anyone help ?

lynnth
11-13-2010, 10:50 AM
That is an error in WordPress itself. It sounds like your WordPress installation has become corrupted. I would suggest re-installing WordPress.

Dan Nickerson
11-13-2010, 10:56 AM
That is most unusual.

Can you share your link?

The Ungifted Marketer
11-13-2010, 11:05 AM
That is an error in WordPress itself. It sounds like your WordPress installation has become corrupted. I would suggest re-installing WordPress.

Not sure i can agree.. Site works fine without theme and is setup exact same as my others ?

The Ungifted Marketer
11-13-2010, 11:06 AM
That is most unusual.

Can you share your link?

Share my link ?

I have upload my own header image via the theme went ok and shows on site but if you go into the headers section and uploads and proceed to click on it you get the same error

Dan Nickerson
11-13-2010, 11:20 AM
Yes, by seeing your URL I was hoping to discover a configuration problem of some sort that would give an answer.

As we've never seen this error before I'm guessing your wordpress setup is unusual. It's one of the reasons we ask for URL at top of forum.

I see you PM'd me.. will check that.

Dan Nickerson
11-13-2010, 11:25 AM
You have different paths in

Settings > General

Make sure the website and blog URL's match. If for some reason you need them to be different and your header is all set for now.. don't worry about the error, it's because of the different directories.

bensky55
11-16-2010, 03:31 PM
Im new to socrates and really like it alot! I cant get the header feature to work though. All I am seeing is a blank white screen. Can someone tell me what I am doing wrong?

thanks

Dan Nickerson
11-16-2010, 04:13 PM
Can you share your link?

What page are you seeing the blank white screen and what browser are you using?

Some simple things to try are to access with a different browser, reinstall Socrates and make sure your Wordpress install is up to date.

bensky55
11-16-2010, 04:16 PM
I am using it on a few sites right now. Here is one of them. I want to use a header that is already in the header section and when I select it, it appears like it works. Than I click save, and it turns white blank.

http://democratsblog.info

thanks

bensky55
11-16-2010, 04:17 PM
I use firefox mozilla

Dan Nickerson
11-16-2010, 04:19 PM
Are you on your own dedicated server? Looks like it based on the whois.

What are your permissions on socrates/header-images/uploads folder?

Can you change them to 777 and see if that works?

Also what is your upload path in your media settings?

bensky55
11-16-2010, 04:26 PM
its not a dedicated server for this site.

is the permissions thing in my ftp?

Not sure where to find my upload path.

Dan Nickerson
11-16-2010, 04:31 PM
We cover all this in the beginning of this thread.

Just start this thread over and we tell you everything to check.

Your problem sounds like a permissions error which you would fix via FTP or a uploads path issue in Wordpress Settings > Media or Miscellaneous

I have to signoff for an hour.

bensky55
11-16-2010, 04:33 PM
K thanks Ill take a gander through the beginning. Ill let you know the outcome

thanks

Ben Barsky

bensky55
11-16-2010, 04:41 PM
I use smart FTP I cant find where to change chmod to 777 can you help me out with this at all.

Thanks

ben

Dan Nickerson
11-17-2010, 08:36 PM
Just select folder or file by clicking on it..

Then right click on it and select "Properties"

You'll see permissions window at bottom of popup screen.

bensky55
11-18-2010, 11:18 AM
IT was the permissions. Once I changed to 777, it did not work. However, I had to go in and click apply to, than check the box apply changes recursively. When I did that, it worked. Thought you would like to know about the apply changes recursively.


thanks for your help with this issue and Im going to start adding headers to my blogs!

Thanks

Ben

Unoentremil
12-01-2010, 06:54 PM
Hi,

Just let know that I have experienced the same problem using IE 8. The files are not uploaded at all.

The upload feature works in Firefox and Opera.

Dan Nickerson
12-01-2010, 08:07 PM
Some people do have an issue with IE8, but it does work in FF, Chrome, Safari, and Opera.

If you are still using IE, I do highly recommend Firefox.. especially if you have an online business.

Unoentremil
12-02-2010, 02:03 AM
Thanks for you your recommendation, Dan.

Yes. I agree. Unfortunately I use several tools developed specifically for IE. In addition, Opera is my favorite browser and Firefox is a must nowadays. So for one reason or another, in the end, I have to deal with four different browsers. Not very productive.

Best regards,
Diego

Dan Nickerson
12-02-2010, 08:44 AM
Diego,

Sorry for the problem. Luckily it only has to be done once, so you should never have to spend more than 30 seconds one-time per blog to get the header setup outside of IE.

Once it's initially setup, there's no longer an issue.

Ricken
12-21-2010, 03:01 AM
I have just bought Socrates but have not applied it to any sites yet. I would love to see a gallery of the headers available. Where can I find it or must I upload Socrates to a site before I can see them?

Thanks Dan.

lynnth
12-21-2010, 05:16 AM
They are displayed on the Socrates header page once you have uploaded it to a site.

tgpaff
12-21-2010, 11:20 AM
Just a FYI for anyone in this thread-- I had same issues of custom header not uploading,
had IE8, solid file name, good wp path, all that was required, only thing I didn't try was the 777-755 change. Tried to upload a few times w/ ie8 and never got it to work, decided to finally install FireFox, did it, upload went right into header space without even having to go to uploads header category!

However, I had already placed a colored background and text in the header space and now I cannot get rid of the original stock header which is now overlaying my custom.
I was able to get it off the Socrates header configuration page but I can't get it off my site, refresh does not work, what should I do?
Thanks in advance.

TP

Dan Nickerson
12-21-2010, 11:24 AM
Can you please share your url?

tgpaff
12-21-2010, 11:28 AM
Thanks Dan-- poweredbyopportunity.com
TP

Dan Nickerson
12-21-2010, 11:30 AM
You just need to delete the header/subheader text in Socrates > Header

tgpaff
12-21-2010, 11:38 AM
Thanks for your quick response. I had already deleted the text but I believe I forgot to save the changes! Had to reload the custom header from the uploads folder, save, and now it's up.
Thanks.
TP

infolosophy
12-31-2010, 08:31 AM
I have done all three of the things listed, Dan (no spaces, etc., settings>media is correct, and changed permissions)...I don't get an error message, but whatever is in the header box stays there, and all the preexisting ones appear to reload again (looking at the url's changing on the bottom of the page)???

Dan Nickerson
12-31-2010, 10:15 AM
What is the filename?

Make sure it has no numbers or punctuation.

infolosophy
12-31-2010, 10:32 AM
:rolleyes: I just read through more of the 11 pages of posts on it and figured that IE8 was my problem...As soon as I tried it in FF everything worked right...I guess there is a reason to read through all the threads, huh?:cool:

Thanks, Dan for a great theme, and Happy New Year!

passive24
01-31-2011, 10:07 AM
After reading through all of this and piecing together different bits. I realized my issue was having the blog point to root level.

Why can't this take place? If I change "Site address (URL)" to make my blog the home page of my website. Socrates Headers than break teh site when selected. Maybe a bug worth fixing?

I have to have my blogs set as home level. When is it safe to change this setting back? When I'm done fully customizing the Socrates theme template? (hope not... :)

Dan Nickerson
02-06-2011, 10:26 AM
Sorry for delay, I've been on vacation and this post got missed.

This honestly hasn't come up yet with over 18,000 installs.. (wow.. hadn't checked this number lately)

You can hard code the header link in this situation if it helps via header.php and style.css

We will look into the bug though.

donathome
02-09-2011, 09:02 PM
I am having the same problem. I am saving my header of choice in Theme 2.1, and saving my background. When I go to view site it has the Socretes default Header.

Also my Clickbank ID is showing up on that page.

When I preview it in dashboard,everything is OK in the post.

I hope you can help.

Don

Dan Nickerson
02-10-2011, 06:56 AM
Can you confirm you've done all the steps we recommend in this thread and also share your URL?

Can you elaborate on your Clickbank ID showing on page?

passive24
02-10-2011, 07:54 AM
Ok Thanks so much Dan!! Hope you enjoyed your vaca and Congrats on 18k installs!!

So I have set the "site address" back to http://www.livingabroadtoday.com/blog/. Everything is fine now. I didn't completely follow you when you mentioned hard coding header.php and css, but the phrase 'hard coding' does frighten me a bit.

What about moving all files to root folder, then switching both blog and site address to root level URL? Will that fundamentally rock any aspect of Socrates? Thanks....

Dan Nickerson
02-10-2011, 09:19 AM
As long as the path is right you shouldn't have a problem.

When I move a blog, I change both paths in Settings > General.

Then I just move all the folders and files via FTP to new location.

passive24
02-10-2011, 10:57 AM
ok, moved all files to root level. Changed both paths to http://www.livingabroadtoday.com/

Both sets of top Nav links for pages still defaulting to /blog/ sub folder. Why isn't that changing when I switch the path? Everything else is working.

lynnth
02-10-2011, 11:33 AM
You will need to reset the nav links by hand

passive24
02-10-2011, 11:37 AM
ouch..and this is best practice? Am I the only one that wants to set the blog as the home root page? Seems choppy. Do I have to get into the theme editor to do that? Thanks for your help Lynn!

Dan Nickerson
02-10-2011, 12:00 PM
It is a pretty rare occurrence.

It should only take 30 seconds or so to remove /blog/ from the links and only need to do one time.

lynnth
02-10-2011, 12:00 PM
No - just go into the Socrates navigation page and adjust the URLs for the nav links.

donathome
02-10-2011, 02:14 PM
Thanks Dan.

I did read the information. My problems were on my end. Theme 2.1 is up and running.

Thank you again.

Don

passive24
02-10-2011, 02:57 PM
Excellent. Thanks Dan and Lynn, guess I'm a loner :), I appreciate your time and great support.

beth
02-14-2011, 12:57 AM
I can select my header but when I go to save it it disappears. I have uninstalled wordpress and reinstalled but it is still the same. Can some one help please.

Dan Nickerson
02-14-2011, 09:01 AM
As we mention at the top of this thread that is usually a permissions error or a problem with your upload path.

Can you check to make sure your Settings > Miscellaneous path is set to the default or: wp-content/uploads

Can you make sure via FTP your header-images/uploads folder has its permissions set to 755, then try to upload, and if that doesn't work 777.

Did you install Socrates via FTP or Wordpress dashboard?

AndySharp
02-16-2011, 05:04 AM
Hey Dan...

I thought the name of the file was the problem, because it had spaces and numbers in it, but I renamed it: "scrapmasterscharlottemonroe" without the quotes.
It is a PNG file.
I resized it in Paint to 960px x 150px.

I'm not sure what else to do?????

Andy

Dan Nickerson
02-16-2011, 08:50 AM
Did you add the .png to the end of it?
Can you try renaming it to .jpg?
Can you attach the file here if those don't help?

AndySharp
02-16-2011, 08:35 PM
Hey Dan,

After hours of trying (to no avail) I finally figured out how to convert that file to a JPEG, and for what.....? NOTHING of course!!

RATS!!! This journey called learning to be an internet marketer, sure is filled with disapointment after disapointment!!

Well... I sure hope you came up with something...?

By the way, at your request, I did send you the attachment of that header.

Cordially,

Andy

Dan Nickerson
02-16-2011, 09:40 PM
Andy,

I sent you the jpeg header five hours ago. I converted for it for you and sent it right back after your email.

Check your spam folder and try that one instead of yours.

If your upload path is correct in Settings > Miscellaneous and you changed the permission on Header-images/uploads to 777, and you're not getting any error messages then I don't have an answer.

If you PM me access to your dashboard and FTP I will fix.

I get really frustrated when customers say they spent hours doing something. Please don't waste that kind of time.

If it takes more than five minutes and you've gone through the forum suggestions please post on the forum and we'll fix for you.

AndySharp
02-17-2011, 05:52 AM
Hi Dan,

I know I'm probably the last guy you wanted to head from... good grief!!

By the way I did get that email from you, but I was gone all day.

Anyway... that header didn't load as you saved it, but I know it's me... I am a marketer, and I have a little technical know how, but not a lot the level of a programer... I'm learning more everyday.

I looked at the settings and the upload path is correct.

I'm not sure what this other thing that you mention is however: "If that doesn't work chmod the permissions on the header-images and sub directories via FTP to 777. Change back to 755 permissions if fixed."

I do want to learn this as opposed to just having someone fix it for me, but I would like to understand better, what does this mean, and how do I do it?

Andy

lynnth
02-17-2011, 06:01 AM
Andy,

Each file and folder on your server has a set of permissions. You can set these either through FTP or the file manager in your hosting account. On some hosts these folders are not being set to the right permissions by default. Permissions of 777 is basically anyone can do anything with folder (full permissions) 755 means that you have full permission and everyone else has read and execute permission (what they need to view files within the folder).

AndySharp
02-17-2011, 07:08 AM
Hey Lynn,

What is "FTP"?

lynnth
02-17-2011, 07:18 AM
FTP stands for File Transfer Protocol. A good free FTP client is Filezilla. If you are not familiar with FTP, your best bet is to use the file manager provided by your hosting service. It tends to be more user friendly.

deejayefem
02-21-2011, 07:53 PM
You just need to delete the header/subheader text in Socrates > Header

does it affect the seo when deleting the header text? i have also this problem which i made my own header with text which overlaying the custom.

Dan Nickerson
02-21-2011, 08:18 PM
It can depending on your other content.

Here's a trick. If you have a custom header you can leave the Title text in there, but in style.css find this...

.titleText h1 { color:#FFF;}

and replace with

.titleText h1 { color:#FFF;display:none;}

This will hide the text from view but search engines will see it.

deejayefem
02-21-2011, 09:20 PM
thanks done it!

how about the sub header/tagline?

Dan Nickerson
02-21-2011, 09:22 PM
It's the description code in style.css

.descText { color:#F0F0F0;padding-top:5px;}

Add the display: none to it.

deejayefem
02-21-2011, 09:29 PM
done it! thanks for the trick.

Hollybopp
03-19-2011, 08:42 AM
I am not techie in the least, learning as i go.

I was curious how do i make a "custom header?" I was looking to expand my choices for headers.

lynnth
03-19-2011, 08:49 AM
You create a 960 x 150 pixel image in the graphics program of your choice. I use Gimp (free download). JPEG or PNG format is best in my opinion.

Hollybopp
03-19-2011, 09:06 AM
thanks l will give it a try.

Mikkin
03-26-2011, 09:54 AM
I have just upgraded to 2.212 and my header title and subtitle don not display properly - the title is aligned higher in the header than before and the subtitle over-rides it.
I have done a repeat install with no improvement.
Changing the font size of the header and subtitle only amakes it worse if they are large enough to look right
Any ideas what is wrong adnd how to fox it?

Dan Nickerson
03-26-2011, 10:13 AM
Our latest version from a few days ago is 2.2.13. You must have downloaded last week and just now upgraded.

Can you redownload from member's area?

Mikkin
03-26-2011, 10:26 AM
Thanks - the problem with the subtitle over-riding the title is now gone but the title won't enlarge from the smallest font size now, although I can change the subtitle font size in the usual way

Dan Nickerson
03-26-2011, 10:33 AM
I've not seen this happen before, might I ask what browser you are using?

As a temp solution you can also use our custom css box in the styling tab and add.


.titleText h1 {
color: #fff;
font-size: 100%;
}


Then increase the percentage until it suits your needs.

Mikkin
03-26-2011, 10:39 AM
Using Firefox - I'll try this custom approach , thanks

Mikkin
03-26-2011, 10:42 AM
The custom css solution make title over-riding the subtitle again unfortunately

here is the site using the custom css set at 130%

www.affiliategenius.net

joybohme
03-31-2011, 06:36 AM
Thank you for your answer.

"You've got a double directory problem, which means you unzipped it to a 2nd directory and uploaded..

Look at your directory path.

/socrates/socrates

Via FTP move all the files from socrates/socrates/ to just /socrates

That will fix."

**** Now, Question again, how do I do that? I don't know much about computer.

Thanks,
__________________

lynnth
03-31-2011, 06:45 AM
Does your hosting account use cPanel? If so, it has a file manager that you can use to look at the files on your server and move the files.

joybohme
03-31-2011, 07:41 AM
Thank you very much!

joybohme
03-31-2011, 10:08 AM
I've spoke to Hostgator Rep. and he walked me through with file management with me. He doesn't see any thing wrong with my socrates them. Now I tried background and change 3 times, funny thing is each pages shows different back ground that I been trying to changed. :rolleyes:

joybohme
03-31-2011, 10:10 AM
I mean my website each pages back ground are all different.

lynnth
03-31-2011, 10:12 AM
What is the URL for this site?

joybohme
03-31-2011, 11:21 AM
http://www.growtaller4idiotscentral.com/

clcick and see webpage background : about me, contact me, privacy policy

Thank's,

Dan Nickerson
03-31-2011, 11:28 AM
You have wp super cache running.

Save your styling tab, and disable wp super cache

KLeeBanks
04-05-2011, 01:31 PM
Hi there!

I just purchased the newest version of Socrates yesterday and my web host friend is helping me set up two new blogs. I uploaded it as a zip file through FTP. I'm having the same problem as many other people (from what I've read here and on the Socrates FAQ page)- my header won't stay "saved" and I end up with just background color.

I don't have that WP super cache plugin and I've gone through all the steps multiple times that you've suggested here and in the FAQs. I'm really anxious to get these two blogs up and running, and I want to promote this theme (already have it listed through clickbank on my other blog, Office Help 4 Hire (http://officehelp4hire.com/blog), in the left hand column).

The blog in question is my new freelance services blog, K'Lee Banks, Freelance Consultant Services (http://kleebanks-freelance-consultant.com).

Thanks for your assistance! :)

lynnth
04-05-2011, 01:55 PM
If you used FTP rather than the WordPress dashboard it is probably a file permission issue. You need to set the uploads directory under the Socrates theme to 755.

KLeeBanks
04-05-2011, 05:11 PM
Thanks for the suggestion - but that didn't work either! :(
This is frustrating - I paid the $77 for an unlimited license, but if I can't get it to work properly, I can't really afford to waste money on it. I was so excited about this theme, too! :confused:

Dan Nickerson
04-05-2011, 06:49 PM
Is there a reason you can't upload normally via the wordpress dashboard?

The best way to fix this is to just delete the Socrates folder via FTP
and then reinstall the zip via dashboard.

It really just looks like permissions issues. When you use the dashboard they are setup properly. When you ftp they have to be changed.

Depending on your hosting config, other permissions could be off as well.

I'd be happy to fix if you want to PM me FTP info, if you can't use the dashboard for some reason.

KLeeBanks
04-07-2011, 04:33 PM
Is there a reason you can't upload normally via the wordpress dashboard?

The best way to fix this is to just delete the Socrates folder via FTP
and then reinstall the zip via dashboard.

It really just looks like permissions issues. When you use the dashboard they are setup properly. When you ftp they have to be changed.

Depending on your hosting config, other permissions could be off as well.

I'd be happy to fix if you want to PM me FTP info, if you can't use the dashboard for some reason.

Hi Dan!

OK, my web host friend has been trying to help me today. She deleted the theme from her FTP.

We have both tried to upload the zip file through the dashboard - whether I do it from my PC, laptop, or her PC - we keep getting this error message:
"The uploaded file could not be moved to /home/kleebank/public_html/wp-content/uploads/2011/04."

The theme did upload when she did it through her FTP, but we just couldn't get the header to load. She changed the permissions, as well, but still can't get it to work.

Please tell me what info you need so you can try to help out - I've read about how many other people you have helped, so I'm sure you can help me as well - I would really appreciate it! :o

Dan Nickerson
04-07-2011, 05:34 PM
There's a few threads on the forum on this and lots in Wordpress as it's a wordpress issue and not Socrates.

First check your available disk space to see if that's an issue.

Next..

In the WordPress dashboard under settings > miscellaneous set the default upload folder to wp-content/uploads.

Make sure the uploads folder exists and set the file permissions on the folder to 777

Then see if you can upload. If you PM me FTP access and dashboard access I can fix for you as well. I'm a fellow Mainiac by the way.

KLeeBanks
04-07-2011, 05:41 PM
There's a few threads on the forum on this and lots in Wordpress as it's a wordpress issue and not Socrates.

First check your available disk space to see if that's an issue.

Next..

In the WordPress dashboard under settings > miscellaneous set the default upload folder to wp-content/uploads.

Make sure the uploads folder exists and set the file permissions on the folder to 777

Then see if you can upload. If you PM me FTP access and dashboard access I can fix for you as well. I'm a fellow Mainiac by the way.




:) OK, thanks - we will try that next - Becky and I are on Google chat right now, working on stuff together.

Yes, I saw your Maine roots listed with your bio! :)

She's interested in communicating with you, too, so I'll PM you my info and hers after I go retrieve it all from an email. Thanks so much!! I've been excited about this theme ever since I started promoting it on my existing blog, so I can't wait for it to actually set up right!

KLeeBanks
04-08-2011, 06:43 AM
:) Thanks, Dan, for all your help last night. It's nice to see both blogs up and running now with the Socrates theme! Becky and I really appreciate your help!

VetteBlue
04-17-2011, 07:06 AM
Uploaded via dashboard. No double directory issue.

wp-content/uploads permissions set to 777 and reset back to 755

Included Socrates Headers do not display. They show up in the control panel when I select them. But when I save they disappear.

What am I missing?

Dan Nickerson
04-17-2011, 11:00 AM
That's the wrong folder to check permissions.

You need to check /socrates/header-images/uploads

The uploads folder should be 777

zijlstra
06-16-2011, 01:23 PM
Hi, the header i am choosing from socrates does not appear on the website. It does appaer ont the Edit Header Text panel and after safe nothing happens on the preview and on the website? I have tried everything? CAn you please help?
Henk from Holland

Dan Nickerson
06-16-2011, 02:16 PM
If you're using IE can you try another browser?

Does the filename have any numbers or punctuation in it?

Can you see image at: yourdomain.com/wp-content/themes/socrates/header-images/filename.jpg

zijlstra
06-16-2011, 11:56 PM
thanks, yes I tried another browser at work, still no.
It is not uploaded from my own file, the headerimage its one from socrates.

Dan Nickerson
06-17-2011, 12:09 AM
Can you share a link to your site?

zijlstra
06-17-2011, 12:12 AM
yes sure: here it is:

http://inruilwaardeautoberekenen.com/

thanks

Dan Nickerson
06-17-2011, 01:02 AM
It's got to be a permission problem on this folder

header-images/uploads/

You need to change permissions on the uploads folder via FTP or file manager to 755, if that doesn't work 777.

I'm just signing off for the night. If you send cpanel or ftp access to me via PM in the morning, I can fix in a few seconds.

zijlstra
06-17-2011, 01:06 AM
thanks.


(http://inruilwaardeautoberekenen.com/wp-admin/edit.php)

Dan Nickerson
06-17-2011, 09:23 AM
Zijlstra,

Please change your wordpress login information immediately. You posted it in a public forum. I had said to PM me which means private message.

I had also requested your cpanel or ftp info.

Once you change your wordpress login info, use our private messaging system to contact me. I need your new wordpress login and domain admin login.

rel323
06-17-2011, 06:49 PM
My Socrates in operating like a breeze in Firefox. However, I discovered a problem in IE the other day and it seems to have mushroomed.

With http://ipodforsale.net, the header does not load. No problem in Firefox or other browsers. In http://greenplanetwaterpurifiers.com, the home page loads completely askew in IE while all other pages load correctly.

Your help is appreciated.

Rel

Dan Nickerson
06-17-2011, 07:17 PM
The problem with the water purifier site is with this post.

http://greenplanetwaterpurifiers.com/24151/the-hydrogenrich-water-stickac/

You've got open div tags you can fix in the html tab of the post editor.

The ipod site is calling this header but it's showing as file not found.

http://ipodforsale.net/wp-content/themes/socrates/header-images/uploads/ipod_header.jpg

Make sure the file is there via ftp and check permissions.

rel323
06-18-2011, 01:20 AM
Once again, Dan, thank you for your prompt reply. Both problems solved. The IE header, for an unknown reason, did not have an image loaded, which was not a problem in my primary Firefox browser.

I am amazed on two levels.

1. IE does malfeasance to my sites the other browsers don't even hint about - makes me wonder how it maintains its status as the predominant browser for the masses.

2. More importantly, it amazes me, with all the questions you must receive, you are able to solve these items so quickly.

Rel

Dan Nickerson
06-18-2011, 08:15 AM
IE maintains it's share because millions of people use the browser that's loaded with their computer and aren't even aware of other options.

I've been doing this stuff since 1994. So most if it's 2nd nature.

odordude
06-23-2011, 01:54 PM
Hi i just had the same problem using IE8. Headers won't load. I have always used Firefox but it has been so slow lately that I changed to IE for the first time in years. Only problem now is headers won't load, and in HTML mode it saves a draft every second......................LOL ARGGHHH!!

Might go back to Mozilla and see if things have improved there

Great to be part of the Socrates group. cheers Dan

annag_5
08-08-2011, 02:44 AM
You've got a double directory problem, which means you unzipped it to a 2nd directory and uploaded..

Look at your directory path.

/socrates/socrates

Via FTP move all the files from socrates/socrates/ to just /socrates

That will fix.
Hi Dan an Lynn,
I think I have the same problem with the socrates/socrates but don't know where to check to know for sure and definitely don't know how to solve it. I am not used working with FTP so if you could explain me the steps in beginner's language I could try to do it. Thanks a lot. Or is there another solution how I can get my header? Thanks, Anna

lynnth
08-08-2011, 04:58 AM
If you post a link to the site I can take a look at the page source and let you know if that is your actual problem.

annag_5
08-08-2011, 06:37 AM
Hi Lynn,

This is the link to the site: http://robomowmower.com/

And this is the error message I receive in WP:

Warning: opendir(../wp-content/themes/socrates/header-images/uploads) [function.opendir]: failed to open dir: No such file or directory in /home/thewor23/public_html/robomowmower.com/wp-content/themes/socrates-1/functions.php on line 2407

Thanks a lot!

lynnth
08-08-2011, 06:59 AM
The problem is not that you have socrates/socrates as your path. It is that socrates was somehoe installed as socrates-1 instead of socrates. I would suggest the following:

activate the default theme
Using the file manager in your hosting control panel rename the socrates folder to be just socrates (remove the -1)
select and activate socrates again

annag_5
08-08-2011, 07:18 AM
Dear Lynn,

Thanks so much!! It works!

Crolika76
09-15-2011, 09:16 PM
Hi, I tried to upload a banner that was custom, and it worked.

When looking at it I realized that the Title Text and the Description were on top of the banner. Since I no longer needed those to viewed, I tried to make them transparent since the Search Engines like this, I assume. The same text in the banner as in the Description.

I tried to place the word transparent in the color choices on the text, and then it stopped working correctly.

I see any choice I want in the panel Header section, uploaded, color or selection of banners, they all appear, but the site does not show anything other than text if it is input.

I used the same banner on another site with Socrates, and it does work.


So I have 2 questions?
1- Please help me get a banner up, at this point, I need at least the ones you offer to make the site look right.

2- When it is corrected, is there a way to make the banner text transparent so we still have the text in there, but it does not come on the banner, or have the text under the banner so we cannot see it when viewing.

We tried doing this change on IE, Firefox, Safari and Chrome, and the same thing happens, we see it inside but not outside for public.

Please assist, I apologize if this was addressed already, but, I did not have time to read all 18 pages. I did review most, but could not wait anymore.

I am using version 2.0, I tried to install the newest version as a last resort, but it did not let me, I would delete, but I don't know how unless I load another them, but I also would rather not set everything up again if possible.

Thank you for your time,
Dan

Please assist.

Thanks,
Dan
site is www.dansbusinessconsulting.com

Dan Nickerson
09-15-2011, 11:02 PM
Your site is not loading for me..

But you should never try to hide text. It's a really bad idea. Just remove the text completely from the header fields.

Did you change the name of the socrates directory?
Did you set your Settings > Media upload path to /wp-content/uploads

bonanzaman
09-16-2011, 03:10 PM
Hi, I've read almost the entire forum and haven't found the answer. When I upload the image it says "file moved XmasForSocrates.jpg
Your changes have been made." But there's nothing there.

Dan Nickerson
09-16-2011, 03:13 PM
Can you share your link?
Did you rename your socrates folder?
Does your settings > media > upload path say /wp-content/uploads/
Did you install Socrates via FTP or Dashboard?

bonanzaman
09-16-2011, 03:21 PM
Can you share your link? top-gift.info

Did you rename your socrates folder? No

Does your settings > media > upload path say /wp-content/uploads/. Yes

Did you install Socrates via FTP or Dashboard? Dashboard

and thanx for the quick reply

Dan Nickerson
09-16-2011, 03:31 PM
Your permissions on your domain are screwed up.

Make sure your image folder permissions are all 755 including

socrates/images
and
socrates/header-images/upload

None of your images are appearing

bonanzaman
09-16-2011, 03:42 PM
I just checked them and they're 755

Dan Nickerson
09-16-2011, 04:12 PM
Something is wrong with them still for example:

Go here:

http://www.top-gift.info/wp-content/themes/socrates/images/completeBg.png

You need to check permissions on other directories like socrates/
and even wp-content/ and /themes

I would try deleting Socrates via FTP and then reinstalling via dashboard.

bonanzaman
09-16-2011, 05:42 PM
I can't find socrates anywhere in the ftp files in order to delete. And I can't figure out how to delete it from the dashboard. It must be frustrating to be dealing with a dummy but I'm mystified. Thanx for your patience.

Dan Nickerson
09-16-2011, 05:56 PM
If you would like to private message me FTP and wordpress dashboard access I will fix.

bonanzaman
09-16-2011, 09:40 PM
Thank you.

Crolika76
09-22-2011, 09:07 PM
Strange that the site did not load for you that day, must have been a burp on the server.

As for the image, I tried everything posted on here, and it did not work. I did delete the file from my file manager and then reloaded the latest version. Still nothing.

Then, for the 10th time tinkering, I gave up, and tried to upload the images offered with Socrates, and I typed in my words. It worked.

I then put my own up and poof, it worked.

Perhaps I ticked something with out realizing, but regardless, it is working now.

I want to thank Dan and his team for being swift with replies and support, unfortunately I was not as speedy as them...")



Your site is not loading for me..

But you should never try to hide text. It's a really bad idea. Just remove the text completely from the header fields.

Did you change the name of the socrates directory?
Did you set your Settings > Media upload path to /wp-content/uploads
__________________
Dan Nickerson
Socrates Creator

dreisinger
10-10-2011, 12:45 PM
Hi,

I had a custom header developed and am not able to upload it. The image is 960px by 150px. I am not getting any error response so I don't know what I am doing wrong. My url is www.intelligentprospector.com.

Please help with any advice.

Thanks.

lynnth
10-10-2011, 12:52 PM
Does the filename have any punctuation in it? That has caused upload issues in the past.

dreisinger
10-10-2011, 01:00 PM
Lynn,

Thanks for the quick response. Here are the filenames I have tried: IPheaderJPG, IPheaderPNG. Neither works.

lynnth
10-10-2011, 01:22 PM
was the period just left off the file name to separate the name from the extension in your post or is it missing from your actual files?

dreisinger
10-10-2011, 01:58 PM
Lynn,

Sorry, the file names are IPheaderJPG.jpg and IPheaderPNG.png. Sorry for the inaccurate data.

Thanks.

Dan Nickerson
10-10-2011, 02:13 PM
Can you upload the files to your Wordpress > Media tab?

What is your upload path in Settings > Media it should be:

wp-content/uploads

dreisinger
10-10-2011, 02:24 PM
Dan,

I can upload it to my media files on WP.

What am I doing wrong on the header upload?

Thanks for your help!

Dan Nickerson
10-10-2011, 03:15 PM
Can you share your link and the path to the header upload and confirm the following?

1. You didn't rename your Socrates directory: it's socrates
2. You've checked your header-images/upload directory permissions
3. Please confirm your path in Settings > media and that it says /wp-content/uploads

Whatever the problem is it's been answered on this thread already we just have to determine which problem.

dreisinger
10-10-2011, 03:31 PM
Dan,

1. Confirmed
2. How do I check the header upload directory permissions?
3. Confirmed.

C:\Users\Doug\Desktop\IPheaderJPG.jpg

Thanks.

Dan Nickerson
10-10-2011, 03:54 PM
Can you please share your link and the path to the file that you uploaded online via Wordpress?

dreisinger
10-10-2011, 07:15 PM
Dan,

I hope this is what you are looking for. If not, please advise on what a link and path are so I can get you the correct info.


http://intelligentprospector.com/wp-content/uploads/2011/10/IPheaderJPG.jpg

Thanks

Dan Nickerson
10-10-2011, 07:55 PM
I see you have another header on your site, so now I'm guessing you have an old version of IE that's causing the problem. I would try uploading with another browser and if that doesn't work.

Add this to Socrates > Styling > Custom CSS box.


#header {width:940px; height:150px; overflow:hidden; padding:5px 10px 0px; background:url(http://intelligentprospector.com/wp-content/uploads/2011/10/IPheaderJPG.jpg) no-repeat;}

Note: Make the link is your full image link.. the forum will shorten it.

jcsites
10-10-2011, 09:51 PM
I'm having the same problem as you are, hope i can find a solution for this...:(

Dan Nickerson
10-10-2011, 10:36 PM
Every solution is posted in this thread.

And I just gave a 10 second fix that can be implemented in the custom css box in Socrates > Styling

dreisinger
10-11-2011, 09:45 AM
Dan,

It was the browser. I uploaded the header using Firefox and it worked like a charm. Thanks for your help!

Timme
10-13-2011, 06:30 AM
Dear,

I'm having this problem.

When i upload my banner i see it , but when i save it goes blanc and i see nothing on my page.

The same for the excisting banners.

I get this error when i upload my image

Just went to FTP en have putted my banner into the uploadsmap, now i can find it easy :)

lynnth
10-13-2011, 06:59 AM
Just to verify - you are all set now?

Timme
10-13-2011, 08:11 AM
Yes tnx it works, solved it myself :).

If there anything else i'll post it

Sitabodang
11-05-2011, 08:37 PM
Dan,
I tried this approach and had no success. I spent 1hr with Hostgator trying to troubleshoot why the header won't upload. It says the changes have been made but when you reload its the same thing.

Dan Nickerson
11-05-2011, 09:09 PM
I'm sorry you spent an hour on this. If you can post your link we can probably tell you the issue right now. Or if you PM access we can fix.

This thread contains many approaches, so not sure which you one you are referencing.

The most common problems are.

1. Socrates directory was renamed, it should just be socrates
2. Your Settings > Media upload path is not: wp-content/uploads
3. Your header file contains punctuation or is an invalid file format.
4. Your permissions are incorrect on header-images/upload

Sitabodang
11-06-2011, 05:16 AM
When I try to load my header, it says that the changes have been made but when I refresh, there is no change. I am unsure what PM access means. Before I contacted Hostgator I was getting a similar message about the directories as the other guy on here...
Warning: opendir(../wp-content/themes/socrates/header-images/uploads) [function.opendir]: failed to open dir: No such file or directory in /home/samuel/public_html/hawaiisolarcompany.com/resources/wp-content/themes/socrates/socrates/functions.php on line 2065 , except of course with my domain name.

After contacting my host and working on this for an hour, the message went away but still no changes. Do I need to uninstall wordpress and start over again? I've already done this once and am wondering if there's some leftover files that are causing the problem.

Sitabodang
11-06-2011, 05:26 AM
I did this,
Goto Settings > Miscellaneous (or Settings > Media in 3.0)
and save the upload path as

wp-content/uploads

Not sure what any of this means;

If that doesn't work chmod the permissions on the header-images and sub directories via FTP to 777. Change back to 755 permissions if fixed.

Sitabodang
11-06-2011, 05:58 AM
There's no problems with Layout, Navigation or Styling. I can change and save those options. When I get to the header section, it says that the changes have been made but when I refresh there's no change. Also, the background seems to have a problem and the message says,
Warning: opendir(../wp-content/themes/socrates/background-images/) [function.opendir]: failed to open dir: No such file or directory in /home/super315/public_html/greatmassagetips.com/wp-content/themes/socrates-2/functions.php on line 1583

Dan Nickerson
11-06-2011, 09:58 AM
As we state at the beginning of this thread and in my #1 bullet, the directory must be named: socrates

Yours is named: socrates-2 Via FTP or your file manager you need to rename the directory to: socrates

If you have Cpanel you would goto File Manager and open up the public_html directory.

Click to /wp-content/themes and then click on socrates-2 and click the "rename" icon above. Then reload your site.

If you would like me to do this Private Message me on the forum with your access info for both Cpanel and WP dashboard.

cherylj
11-27-2011, 08:04 AM
I am lost as to where my original post is, so I am posting my results here.

Renaming, Filezilla, those suggestions did not work for me.

The one thing that did work was I went to the CPanel and went to Socrates...Header Images...Uploads....and then clicked on that...the next screen showed the current header, I hit Upload and uploaded the image. Then I was able to go back into the Admin area at my blog and click on the image and it switched out as the header.

The one other problem I found is that resizers differ, one will say 960 when it is 962 in another resizer, so I changed it to 959.

With those changes, I was able to upload the image.

From now I will go into CPanel to upload images when I cannot do it otherwise.

Dan Nickerson
11-27-2011, 09:37 AM
That will work but you should not have to take the extra step or even resize the header. Most likely your header issues are related to one of the reasons listed in this thread.

cherylj
11-27-2011, 10:12 AM
That may be true, that there might have been an easier way, but I just couldn't make it work.

And I have to add that even by doing the C Panel way, I was not entirely successful with some of the blogs. In some cases, I had to upload the newest Socrates upgrade...deleted the old...added the new...per the Socrates instructions...before the CPanel method I was using worked.

At the end of the day, I just want to get it done. If I could have figured it out easier, maybe I don't understand a technical term or something, I would have done it, but getting it done is really I want in the end.

Dan Nickerson
11-27-2011, 10:33 AM
Sorry for the issue.

Next time if you have an issue just PM me wordpress and cpanel access and I can probably figure out the issue and correct in seconds.

freddyjr
12-07-2011, 01:19 PM
I tried to change my header today but I can't!

I can edit everything but whenever I click on "Save" it takes me to a blank page!

The Url is below↓ - My site is www.how2improvethememory.com

http://www.how2improvethememory.com/wp-admin/admin.php?submit-titleText=&submit-descText=&submit-hColor=B3FF1C&submit-dColor=FF0D05&submit-bgColor=&submit-align=right&submit-titleFont=Georgia%2C+&submit-descFont=Georgia%2C+&submit-titleFontSize=330%25&submit-descFontSize=140%25&headerUrl=http%3A%2F%2Fsocratesheaders.s3.amazonaw s.com%2Fhealth%2FLowCostGroceries.jpg&siteTitle=&siteDesc=&titleFont=Georgia%2C+\%22Times+New+Roman\%22%2C+Ti mes%2C+seri&descFont=Georgia%2C+\%22Times+New+Roman\%22%2C+Tim es%2C+serif&hColor=B3FF1C&dColor=FF0D05&socHeaderBgType=image&bgColor=FFFFFF&customHeader=&header-Submit=1&save=Save

PLEASE HELP ME!!

I have this new header I need to put up and I can't:confused:

I will appreciate any help !!

Thank you very much!

lynnth
12-07-2011, 01:30 PM
The second link is of no use to us because we would need you admin username and password to go there (please don't post either to the forum! If you want to PM them to one of us we can take a look.). Does your filename for the header have any characters in it other than letters? That has caused issues in the past. I see a custom header on the site now. I assume you have been able to upload headers in the past so you probably don't have a folder permissions issue.

freddyjr
12-07-2011, 01:41 PM
Yeah I thought the link wouldn't be of much help!

I had no problems before today, I changed the header a lot of times and I think it is because I used a special character, I think!

I used blank spaces at the end of the title and description. "alt + 255" is what I used for the blank spaces. I did this because I wanted to move the title and description. Obviously it didn't work!

I can give you my password and username in PM but I would like that to be my last resource!

is there any way I could fix this?
I think it is because I have used the special character, what do you think?

Thank you very much for your help!

Dan Nickerson
12-07-2011, 04:07 PM
Just make sure your header is named something like.

header.jpg

Right now it's named:
Improve_The_Memory_Header20.png

Then reupload it..

The alt code would have no impact

freddyjr
12-07-2011, 05:47 PM
it doesn't matter what I do I change the header, use a solid color, write something else, everytime I click it takes me to a blank page and never saves anything. I tried deactivating and activating the theme but won't fix anything.

I also tried deleting the socrates theme manually but same results!! How could I delete Socrates completely so when I get it again i will have to type in the activation code? because as for right now everytime I delete Socrates from my site n re install it again - all the settings are the same and theme is already unlocked, why? is there any extra file I should delete ?

thanks for your help!!

Dan Nickerson
12-07-2011, 07:20 PM
If you can just PM me your access info I can fix quickly.

I see the header file name is still the same, did you put anything in the custom css box for the header? If so, delete it.

I'm sure I can easily resolve if you just PM access.

The other thing you can try is to upload this file manually via ftp or file manager to this location.

wp-content/themes/socrates/header-images/uploads/Improve_The_Memory_Header20.png

Deyanira Hernandez
12-18-2011, 04:46 AM
In the header section displays the following message


Forbidden

You don't have permission to access /headers/headerpicker2.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache mod_fcgid/2.3.6 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at banx.socratestheme.com Port 80

Dan Nickerson
12-18-2011, 06:56 AM
We have a message in the members area about this. It's related to yesterday's issues and should be fixed today.

Sorry for the problem.

pam
01-03-2012, 01:59 PM
Similar issues... I have had my sight up and running for several months and yesterday decided i wanted to change the header. I made a header and tried to upload it through the header button thing. I get this ....Warning: opendir(../wp-content/themes/socrates/header-images/uploads) [function.opendir]: failed to open dir: No such file or directory in /home/rafa/public_html/howtolosefatforwomen.com/wp-content/themes/socrates/socrates/functions.php on line 2281

so I tried to move the lower socrates folder into the other one in file zilla and it just says its a similar path and doesn't move it. I am so bad at this part of the computer. I just don't want to screw up my site.

I have snooped through the file manager thing in cpanel and snooped in filezilla to just locate a folder that has those ready made headers in it thinking maybe I could just put my header in there! I can't find that stuff either. I really don't know what I am doing. Also, my header is the right size etc... here is the info... my website is howtolosefatforwomen.com the image I want to use for my header is headerfatlosswomenbabymegsmaller.png or headermeg.png I went to file zilla and just put the image in a couple of places to see if that changed anything. Nope! I am really a novice at this part. I apologize in advance for my ignorance! Sorry!

Dan Nickerson
01-03-2012, 02:33 PM
It's definitely a double directory issue.

It's just a matter of moving all the files. You highlight all the files in socrates/socrates and drag them to the first socrates folder in Filezilla.

You'll then have to reset Socrates as the theme when you log back in.

You can't hurt anything if you just try dragging those files.

Another option is to just delete the socrates folder, the first one.. and then just reinstall using the original zip.

pam
01-03-2012, 03:05 PM
Thanks for the reply! I just tried to drag the lower folder into the other one and it bounces back and says "source and path of the drop operation are identical" If I delete the top socrates folder and reinstal from the zip file, will I lose my site as it is and have to start over?
thanks again.

pam
01-03-2012, 03:12 PM
One other thought I had...I really just wanted to add a small image to the right side of the existing header and couldn't figure out how to do that so that is what lead me to think it would be easier to add a whole header. Is there an easy way to just add that small image to the header? Just a thought. thanks

Dan Nickerson
01-03-2012, 05:29 PM
I never said to drag the folder. You need to select all the files and folders inside socrates/socrates and move them.

If you delete Socrates you will not lose anything as it's already stored in your database. You'd lose any custom changes you may have made to the template files and that's all.

If you want to put code into your header we have a thread on this here.
http://www.socratestheme.com/forum/showthread.php?t=793

mario
05-02-2012, 09:17 AM
i am having the same error trying to upload a simple header image. I've looking for a fix, but can't figure this out.

help please


Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpHoVUcc' to '../wp-content/themes/socrates/header-images/uploads/SupHeader.jpg' in /home/content/85/6413385/html/supdesigns/wp-content/themes/socrates-5/functions/panel/themeoptions.php on line 493

mario
05-02-2012, 09:35 AM
I can't figure this out.
Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpMnhjT4' to '../wp-content/themes/socrates/header-images/uploads/supheader.jpg' in /home/content/85/6413385/html/supdesigns/wp-content/themes/socrates-5/functions/panel/themeoptions.php on line 493

I've been reading the posts but still stuck.
can you help me with this.
thanks

mario
05-02-2012, 09:51 AM
I can't figure out how to fix this: Warning: move_uploaded_file(../wp-content/themes/socrates/header-images/uploads/supheader.jpg) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/content/85/6413385/html/supdesigns/wp-content/themes/socrates-5/functions/panel/themeoptions.php on line 493

I've red everything posted.

lynnth
05-02-2012, 10:01 AM
You only need to post an issue once Mario. Answered in the other thread. You have socrates installed under the wrong name.

kj106
05-07-2012, 01:13 AM
Hi,
I have the latest versions of WordPress and Mozilla Firefox. I could change my Header initially but now all that comes out is a blank white background with my title reduced in size. I do not know what permissions are and how to change them to 777. Please help. Thank you.

Forum Admin
05-07-2012, 07:27 AM
Hi,

If you'd like I can take a look. Send me the site credentials via PM or helpdesk (https://socratesthemehelp.zendesk.com/home).

jbowker
11-13-2012, 12:54 PM
Hello. I have the latest theme and I can't get my header to load. I made sure it was 960x150 pixels in size and the extension ends in .jpg, .gif, .png. I have tried several times. There is no error message, it just doesn't show up in the uploaded section of the headers after I save. Any advice?

Thanks,
John

Dan Nickerson
11-13-2012, 04:04 PM
Does the file name have any numbers or punctuation in it?

jbowker
11-13-2012, 09:26 PM
No, the file name is usebanner.png and I also tried usebanner.jpeg but neither of them worked and I double checked and the banner is 960x150.

Dan Nickerson
11-14-2012, 08:31 AM
When you say you tried other extensions. I assume you resaved the image using a graphics editor as the different extension and just didn't save it.

Can you upload the file via the Media upload feature and see it? My guess is the file is corrupted somehow, or it's a permissions issue.

You can also try uploading to the header-images/uploads/ folder via FTP or your file manager.

jbowker
11-14-2012, 08:42 AM
I made the banner in snagit and then saved it to my laptop in both png and jpeg formats and then tried to upload them as my haeder from my desktop (trying one at a time with no success). I just tried loading them into the media area and they loaded in just fine. If it is a permissions issue, how do I fix that?

donathome
11-14-2012, 09:00 AM
Hi Dan,

I haven't experienced this problem, but I am thankful I jumped in here, as I learned a lot.

Don

jbowker
11-14-2012, 09:08 PM
Hey Dan,

Got it figured out. Per your suggestion, went the FTP route and it worked like a charm. Thank you very much!

John

creativegifts
03-01-2013, 03:35 PM
Okay, I thought this was supposed to be easy. I'm using your trial, chose a header image from your choices, saved and bingo -- NO HEADER IMAGE. I've used other themes on this site and images have never been a problem. Why can't your image show up? This looks like a good theme but I'm discouraged with it already. The site is www.shopcreativegifts.com/blog

Dan Nickerson
03-01-2013, 07:36 PM
It is certainly designed to be easy and with over 100,000 installs, easy is the most common perception from our customers.

The first thing I noticed on your site is that the other images in your posts are broken. So my first guess is that it's a permissions issue with your domain or a problem with your upload path.

Can you upload images from the media tab? Can you try saving your Settings > media upload path again?
If it still doesn't work you might want to check your ftp permissions on your upload folder.

henyo
03-12-2013, 02:21 PM
Hi Dan,

I've got a problem with my header. It just comes up with a white header even when I select one of the theme images or even a colour. No error message though. I've tried changing my browser (from chrome to firefox), changing file permissions on FTP and deleting socrates from WP and FTP and re-installing. Nothing seems to be working, I hope you can help.

Site is www.theconfidenceresource.com

Thanks

Dan Nickerson
03-12-2013, 02:35 PM
This is strange.. it looks like you have multiple installs and are linking to them from your header. Each link is setup differently.

Why are you setting up the site this way? You only need one install, and maintaining multiple installs will only cause problems.

There's just no need to do this.. you should look into custom post types.. it's probably perfect for what you're trying to do.

As far as why the header isn't appearing.. I'm not sure if you've checked everything.

Can you just goto this file via FTP and change permissions to 777 and see if it appears
http://www.theconfidenceresource.com/wp-content/themes/socrates/header-images/uploads/socJigsawPuzzles.jpg

Also, can you upload images from your media tab and do they appear on the site?

henyo
03-12-2013, 03:09 PM
Thanks for your quick response

http://www.theconfidenceresource.com...sawPuzzles.jpg that file no longer exists in the FTP header-images/uploads file. I tried changing the permissions on another image but still no luck.

I can upload images from your media tab and they do appear on the site.

Thanks for the advice about the installs, I was recommended to do it that way to help prevent Google penalties affecting every section of the site if necessary - very new at this so probably need to read up on this more!

lynnth
03-12-2013, 03:35 PM
Did you try changing the permissions on socArchaeology.jpg since that is the header you are currently using? Also make sure that the folders in the path to the image file are also set to permit reading.