PDA

View Full Version : Cannot edit font color for links; just for "no-sidebars" template



windsoraffiliates
07-28-2010, 10:12 AM
The Socrates > Styling panel does not appear to apply the selected font color to links and link-hovers when using the "no-sidebars" template. The font just stays almost black, so it's not clear that there is actually a link.

http://buzz-on-bees.com (WP 3.0 + allinone SEO 1.6.12.1 plugin)

Thanks, windsoraffiliates.

compusol
07-31-2010, 06:35 AM
I'm assuming that you found the answer to your question as when I view your site the links in your content are quite normal, blue then underlined on hover.

The post title headers are black, but that's the way they are meant to be.

windsoraffiliates
07-31-2010, 01:36 PM
Hi compusol, thanks for responding.

I have observed this phenomenon for all 8 sites I have created so far: the Socrates>Styling menu is not working to control font colors on the no-sidebar template.
Check out the attached screencaps of pages created either with the no sidebar template or the default template.
(http://donteventhinkofusingthiscutedomainname.com/)(Socrates 2.03; WP 3.0; no plugins)

PS It's great to have such an active support community—one more benefit that comes with this product.

Dan Nickerson
07-31-2010, 02:51 PM
We're aware of this bug.. and I sent this thread to Jon to fix..

Sorry for the problem, we should have solution soon.

lynnth
07-31-2010, 02:52 PM
It is probably because the skinny sales page has its own CSS file.

jonc
07-31-2010, 04:18 PM
That setting will only change the link color in posts, not in pages. You can make it also change the link color in pages by finding the following line in header.php:


<style type="text/css">
.titleText {color:#<?php echo $header['hColor']; ?>; margin:20px 0px 0px}

and changing it to this:


<style type="text/css">

.page a {color:#<?php echo $style['postColor']; ?>}
.page a:hover {color:#<?php echo $style['postHover']; ?>}

.titleText {color:#<?php echo $header['hColor']; ?>; margin:20px 0px 0px}

This will cause both your links in posts and pages to match that setting.