Please Read First
Troubleshooting Tips
Frequently Asked Questions
Before Posting Please Disable Wp Super Cache Plugin
When Posting Please Include Your URL.
Search Forum Using Google Search Box Above
Forum Video

Results 1 to 7 of 7
  1. #1
    Join Date
    Jul 2010
    Posts
    32
    Rep Power
    0

    Default Problem with navigation :(

    OK,

    I've been tweaking my site as I go and have changed a lot of things since I launched the site.

    My problem is my Nav links; Specifically, my "contact" and "about" links. All the other ones work fine, but they were set up more recently.

    Those were my first 2 pages I set up after my home page. My link structure is set up as:

    /%postname%/

    The permalinks for the pages are are set up as "/pagename" and not the default wp structure.

    The problem with those 2 links is that they display the /?page_id= format in the task bar when you hover over them and just redirect to my homepage. I have them set up in the navigation as "/about" & "/contact", but they still show the default WP format?

    I'm not sure what I did wrong. I did recently install WP super Cache, but that was like 2 days ago. Do I need to disable it and reset the link structure again? I'm still a bit wet behind the ears, so...

    Help?

    http://floname.com

    BTW: I just noticed that the problem only exists on the Homepage: The links seem to work fine if you link to them from any of the other pages including post pages. Seems like a cache issue?
    Last edited by floname; 09-07-2010 at 10:04 AM.
    Check me out at Floname.com - the domaining blog devoted to newcomers!

  2. #2
    Join Date
    Jun 2010
    Location
    Binghamton, NY
    Posts
    2,732
    Rep Power
    8

    Default

    It looks like the link in the Socrates nav page still has the pre-permalink URL. My suggestion is to:
    1. go into the Socrates Navigation page
    2. delete the contents of the URL boxes for each of these
    3. drag the link for each from the list on the right side of the page to the appropriate box
    4. Save the changes


    This should clear the issue.
    Lynn T. Harrison
    Ever Evolving Enterprises
    LynnTHarrison.com (my blog on using WordPress) Testimonials appreciated

  3. #3
    Join Date
    Jul 2010
    Posts
    32
    Rep Power
    0

    Default

    OK Lynn,

    tried that and it doesn't work..

    I even disabled the WP supercache and still no luck.. It's weird that it only seems to be a problem on my homepage.. The links work fine from any page other than the hompage..
    Check me out at Floname.com - the domaining blog devoted to newcomers!

  4. #4
    Join Date
    Jun 2010
    Location
    Binghamton, NY
    Posts
    2,732
    Rep Power
    8

    Default

    If you want to send me a private message with an admin username & password, I can take a look for you.
    Lynn T. Harrison
    Ever Evolving Enterprises
    LynnTHarrison.com (my blog on using WordPress) Testimonials appreciated

  5. #5
    Join Date
    Jul 2010
    Posts
    32
    Rep Power
    0

    Default

    Thanks Lynn,

    PM sent
    Check me out at Floname.com - the domaining blog devoted to newcomers!

  6. #6
    Join Date
    Jun 2010
    Location
    Binghamton, NY
    Posts
    2,732
    Rep Power
    8

    Default

    This is the strangest thing I've seen in awhile. The navigation settings should be common no matter which page is currently being displayed. I haven't found a reason so far, but I'll keep looking.
    Lynn T. Harrison
    Ever Evolving Enterprises
    LynnTHarrison.com (my blog on using WordPress) Testimonials appreciated

  7. #7
    Join Date
    Jul 2010
    Posts
    32
    Rep Power
    0

    Default

    Thanks for your help Lynn, hope you can find the issue..
    Check me out at Floname.com - the domaining blog devoted to newcomers!

Similar Threads

  1. Navigation/Pages Problem
    By organicrider in forum Official Support 3.0
    Replies: 2
    Last Post: 06-25-2010, 10:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •