Please Read First
Troubleshooting Tips
Frequently Asked Questions
Before Posting Please Disable Wp Super Cache Plugin
When Posting Please Include Your URL.
Search Forum Using Google Search Box Above
Forum Video

Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Join Date
    Jun 2010
    Location
    Maine
    Posts
    7,452
    Rep Power
    12

    Default Why is my layout messed up and sidebar gone?

    Misformatted html code can wreak havoc on any site design.

    With so many people adding links, image links, div styles and other html code to posts and widgets, invariably bad code will get used.

    If you see your sidebar drop below your posts, or the footer image appear at top of posts then chances are you have an extra div or "a" tag in your code.

    Check all your the links or banner image codes you manually entered in Socrates layout fields or widgets.

    Look for an extra or missing "a" tag. Every open <a> tag needs a closing </a> tag Every open <div> tag needs a closing </div> tag.

    If there's no issue with your widgets or layout fields then the problem might be in a post.

    Open each post in a new window.. the good posts will look normal, the bad post will look misformatted.

    Edit that post and look for an extra or missing tag and that should solve the problem.

  2. #2
    Join Date
    Jun 2010
    Posts
    2
    Rep Power
    0

    Default Side Bar appears below posts

    I saw your forum post regarding this problem, but I've got a curious twist on this. My blog looks fine in Firefox, but it's on Internet Explorer that the side bar appears below the posts.

    Why would that happen?

    I've removed all the widgets and then the page listings appears below the posts.

    So even with no widgets, the problem exists in IE. ???

    Thanks for your help.

    JC

  3. #3
    Join Date
    Jun 2010
    Location
    Binghamton, NY
    Posts
    2,732
    Rep Power
    8

    Default

    Then the problem is mis-matched tags in either an ad block or a post on the page. Some browsers can correctly guess what the HTML is trying to do even if the tags don't all match up. IE rarely can.
    Lynn T. Harrison
    Ever Evolving Enterprises
    LynnTHarrison.com (my blog on using WordPress) Testimonials appreciated

  4. #4
    Join Date
    Jun 2010
    Posts
    2
    Rep Power
    0

    Default Thank You!

    You were right! Thanks. I really appreciate your help.

    I was missing a tag in an ad block.

  5. #5
    Join Date
    Jun 2011
    Posts
    3
    Rep Power
    0

    Default Problem with sidebars

    I have a similar problem with my primary and optional sidebars on one of my sites.
    When I'm in my homepage - somehow these sidebars showing at the bottom of my posts, but when I click on my posts - everything looks perfect inside. Sidebars are in the right place.

    And by the way - I tried to open this site in different browsers - still the same problem.
    I also checked the ad block coding - everything is fine! What can cause a problem in this case?

  6. #6
    Join Date
    Jun 2010
    Location
    Maine
    Posts
    7,452
    Rep Power
    12

    Default

    Can you share your link? It's impossible to answer without.

  7. #7
    Join Date
    Jun 2011
    Posts
    3
    Rep Power
    0

    Default Link

    http://decorating.homegarden-ideas.com/

    I just checked it again - and now it seems to be working fine... hmmm...
    I don't know what was a problem... but both sidebars where underneath posts... and I couldn't do anything about it...

  8. #8
    Join Date
    Jun 2010
    Location
    Maine
    Posts
    7,452
    Rep Power
    12

    Default

    Most likely it was your ads overrunning divs... and something got resized to correct it.

    To be honest you're running too many ads.. You should remove the inpost adsense ad.. it's just too much for your visitors.

  9. #9
    Join Date
    Jun 2011
    Posts
    3
    Rep Power
    0

    Default Thanks

    Thanks for suggestions!

    I'm just trying to test different ad locations for better results.

  10. #10
    Join Date
    Mar 2011
    Posts
    8
    Rep Power
    0

    Default

    All of my tags are showing up on home page instead of inside post-only. I want to hide them from the home page so that they are only visible when that post is opened.
    http://www.myipadapps.com

Similar Threads

  1. layout
    By cecil1 in forum Wordpress Errors
    Replies: 2
    Last Post: 10-22-2010, 04:36 PM
  2. Layout right to left
    By Nirb in forum Official Support 3.0
    Replies: 2
    Last Post: 10-15-2010, 01:24 PM
  3. The Layout desings are missing in layout category.
    By arya commercial in forum Official Support 3.0
    Replies: 4
    Last Post: 08-30-2010, 01:04 PM
  4. Layout
    By gordonmartin in forum Official Support 3.0
    Replies: 2
    Last Post: 08-20-2010, 03:02 PM
  5. I messed up - All Category Posts on Main Page
    By rickghouse in forum Community Support
    Replies: 31
    Last Post: 07-17-2010, 10:36 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •